Beginner mistake! Menu component not working

Hi!
I just tried to change my site from foundation 6.6.1 to 6.6.3. I had an issue with the orbit component and got the impression from github that the update solved it. However updating the version causes the dropdownMenu component to stop working. I think it has to do with how i link to the scripts. What is the correct way to do this and what files do i need to reference from foundation and other sources such as jquery? Should these script tags be in the head or just before the </body>?
Please help.

Right before </body> in this order:

  • jquery.min.js
  • foundation.min.js
  • $(document).foundation();
  • the rest of your scripts which depend on Foundation Sites
2 Likes