Cannot change gutter size in XY grid

When I attempt to change the gutter size using variables in _settings.scss, nothing changes in the rendering or in the output css. For example, just to easily visually see the difference, I have the following:

$grid-column-count: 12;
$grid-column-gutter: (
     small: 200px;
     medium: 100px

);
$grid-margin-gutters: $grid-column-gutter;
$grid-padding-gutters: $grid-margin-gutters;
$grid-container-padding: $grid-padding-gutters;

The HTML code in question has a main element with .grid-x and .grid-padding-x and child div element with .cell.
No matter what I put in the variables, the padding for that cell remains:
.grid-padding-x > .cell {
padding-right: .9375rem;
padding-left: .9375rem;
}

Should that not change? If not, how do I get that to change?

More information: I tried to use the xy-gutters mixin and I’m getting an error message that it’s undefined.

You need to @import ‘…/foundation/settings’; above the class that uses the mixin. If you don’t first @import it, then the mixin will be undefined. Try reading more about sass and how it works here: https://sass-lang.com/
Be aware that sass is switching @import to @use, however, atm foundation uses @import. More info here: https://sass-lang.com/blog/the-module-system-is-launched

“settings” is already imported (been using SASS for a number of years), and other mixins seems to be working just fine. I’ve just decided to solve my problem in another way, as it’s not worth spending time trying disentangle the layers and layers of imports to find this.

I will check that. The values should change.

Which exact version of Foundation Sites do you use?

For me it works with the zurb-template which results in

.grid-padding-x > .cell {
  padding-right: 6.25rem;
  padding-left: 6.25rem; }
  @media print, screen and (min-width: 40em) {
    .grid-padding-x > .cell {
      padding-right: 9.375rem;
      padding-left: 9.375rem; } }

Keep in mind that there is a start and build script.

I’m using Foundation 6, with the Basic Template. And it is version 6.6.1. I just installed it 2-3 weeks ago. And I still get no change. I’m using the npm installation, and it appears to be building just fine otherwise.

Please provide a small repository with your code as reproducible testcase.

The repo is on BitBucket. I can share that with you if I get an email, unless you have an alternative method you’d prefer.

We would need a public repo - on GitHub. With just the needed code.
Otherwise just I can help but I have not so much time.

I appreciate the offer of help, but I’m afraid I don’t have a lot of time right now to work with it. I was able to make it work in another way for this purpose, and I can revisit it at another time. Thanks!