Foundation 6.6+ SASS compilation bug cell widths

Seems to be an issue when compiling the Sass of Foundation 6.6+. All small-up-x, medium-up-x classes are applying the same 100% width to their cells…

.small-up-1 > .cell {
    width: 100%; }
  .small-up-2 > .cell {
    width: 100%; }
  .small-up-3 > .cell {
    width: 100%; }
  .small-up-4 > .cell {
    width: 100%; }
  .small-up-5 > .cell {
    width: 100%; }
  .small-up-6 > .cell {
    width: 100%; }
  .small-up-7 > .cell {
    width: 100%; }
  .small-up-8 > .cell {
    width: 100%; }

Also getting weird things like this…

  .grid-x > .small-1 {
    width: 8.3333333333%; }
  .grid-x > .small-2 {
    width: 8.3333333333%; }
  .grid-x > .small-3 {
    width: 8.3333333333%; }
  .grid-x > .small-4 {
    width: 8.3333333333%; }
  .grid-x > .small-5 {
    width: 8.3333333333%; }
  .grid-x > .small-6 {
    width: 8.3333333333%; }
  .grid-x > .small-7 {
    width: 8.3333333333%; }
  .grid-x > .small-8 {
    width: 8.3333333333%; }
  .grid-x > .small-9 {
    width: 8.3333333333%; }
  .grid-x > .small-10 {
    width: 8.3333333333%; }
  .grid-x > .small-11 {
    width: 8.3333333333%; }
  .grid-x > .small-12 {
    width: 8.3333333333%; }

Issue isn’t present in v6.5.3

Can anyone confirm?

Anybody else seeing the same? Or am I doing something wrong?

Hi, i don’t have this problem after generating css from scss, using Foundation Sites 663

.grid-x > .small-1 {
  width: 8.3333333333%;
}

.grid-x > .small-2 {
  width: 16.6666666667%;
}

.grid-x > .small-3 {
  width: 25%;
}

.grid-x > .small-4 {
  width: 33.3333333333%;
}

.grid-x > .small-5 {
  width: 41.6666666667%;
}

.grid-x > .small-6 {
  width: 50%;
}

.grid-x > .small-7 {
  width: 58.3333333333%;
}

.grid-x > .small-8 {
  width: 66.6666666667%;
}

.grid-x > .small-9 {
  width: 75%;
}

.grid-x > .small-10 {
  width: 83.3333333333%;
}

.grid-x > .small-11 {
  width: 91.6666666667%;
}

.grid-x > .small-12 {
  width: 100%;
}

Hmm, strange, what are you using to compile the scss?

Anyone got any ideas why I would be getting this in 6.6 but not 6.5.3?