'Marketing Site Footer' building block not working?

Hello all!
Sorry in advance if this is a stupid question, but after an hour of futile tinkering I’m stumped and reluctantly must throw in the towel and appeal to the experts.

I like the ‘Marketing Site Footer’ building block (https://get.foundation/building-blocks/blocks/marketing-site-footer.html), but I’m having trouble making it appear as shown. I even tried a blank HTML page, to see if perhaps one of my CSS rules was interfering with the CSS provided, but no such luck, the elements are appearing as shown below.

What am I missing here?
Screenshot: https://i.imgur.com/tjVAIPg.png

Thanks in advance!

The block uses the old flex / float grid which uses the classes row and columns.
Foundation 6.6 uses the new XY grid by default.

You either have to use grid-x and cellor switch to the flex / float grid version.

1 Like

Sorry it took me a while to thank you. You are a lifesaver! That was driving me insane and I couldn’t figure out why.

So I’ve been tinkering with it, spending (probably excessive) time trying to convert it to XY-grid. Unfortunately, my Foundation-fu is still not quite where I want it to be, although I feel like it’s almost there

This is what I’ve got so far:

What do I need to make it best resemble the original?