Newbie Question: How to upgrade 6.5.3 => 6.6.1?

Sorry for this kind of newbie question, but…

How Do I upgrade my existing installation of Foundation Sites from version 6.5.3 to 6.6.1?
foundation update says “Nothing to update. You’re good!”

Do you use npm? If so you can do that with npm update foundation-sites if there is the ^6.... SemVer range in your package.json file.

The CLI uses bower, see https://github.com/foundation/foundation-cli/blob/0cd91f0cb19c3101f7dbad7d33ca7d5ddd873a2f/lib/commands/update.js

So this might be wrong. Please check if there is a bower.json and its content.

Maybe bower has a problem with the old repo URL at https://github.com/foundation/foundation-sites/blob/aa82df837f324205a8233bae3fa8e1ae828eba42/bower.json#L32

We might have to test this.

I don’t use bower and there is no bower.lock. I tried yarn but it doesn’t update anything too.

my package.json looks like this:
{
“name”: “foundation-sites-template”,
“version”: “1.0.0”,
“description”: “Basic template for a new Foundation for Sites project.”,
“main”: “gulpfile.js”,
“scripts”: {
“start”: “gulp”,
“build”: “gulp sass”
},
“author”: “ZURB <[manually removed due to new user url restrictions (2 max)]>”,
“license”: “MIT”,
“bugs”: {
“url”: “https://github.com/zurb/foundation-sites/issues”,
“email”: “[manually removed due to new user url restrictions (2 max)]”
},
“dependencies”: {
“foundation-icon-fonts”: “^0.1.1”,
“foundation-sites”: “6.6.1”,
“gulp”: “^3.9.1”,
“jquery”: “>=3.0.0”,
“motion-ui”: “^2.0.3”,
“what-input”: “^4.1.3”
},
“devDependencies”: {
“gulp-autoprefixer”: “^3.1.0”,
“gulp-load-plugins”: “^1.1.0”,
“gulp-sass”: “^3.1.0”
},
“repository”: {
“type”: “git”,
“url”: “https://github.com/zurb/foundation-sites-template.git
},
“private”: true
}

… and

npm update foundation-sites

doesn’t seem to do anything too.

Hm… I was obviously wrong. Looks like something of the above in fact worked now…
Maybe it had something to do with missing MS Windows-Privileges (Switched my account to admin-rights recently).

Source code seems to be updated now as well as version numbers in node-modules/foundation-sites:

  • README.md says: npm/bower package 6.6.1
  • package.json: “name”: “foundation-sites”, “version”: “6.6.1”, …
  • meteor-README.md: Foundation for Sites (v 6.6.1)

whereas

  • package.nuspec: <metadata><id>foundation-sites</id><version>6.5.3</version>

the latter might be a bug…

Thanks for your support anyway!

You already have the last version. Only package.json is relevant.

Bower is deprecated, we migrated away from it and bower has no lock files.

And the 6.5.3 in the nuspec is a mistake by us, see https://unpkg.com/foundation-sites@6.6.1/package.nuspec.

bower is used by foundation-cli in the background, see my previous link.

We should check if foundation update still works. But I guess the bower package registration is the problem and bower itself did not find the new releases.

Same problem here.
Perhaps npm update foundation-sites would work, if I had a node_modules/foundation-sites somewhere, but instead I have a bower_components/foundation-sites and running foundation-cli’s foundation update (which uses bower) doesn’t do anything.
Setting dependencies.foundation-sites to ^6.6.0 in bower.json doesn’t help…

EDIT: Or maybe it did, but silently? It looks like my bower_components/foundation-sites is now indeed 6.6.1, with the 6.5.3 mistake in its nuspec all right. This response might thus be null and void.