Python 2 still required?

Does Foundation, or its dependencies, still require Python 2? I would like to remove it from my system.